const regex = new RegExp('^lease.*(\\n)*{$', 'gm')
const str = `lease 192.168.0.1
{
`;
const subst = `\\$0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);