use strict;
my $str = 'lease 192.168.0.1
{
';
my $regex = qr~^lease.*(\n)*{$~mp;
my $subst = '\\\\$0';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";