// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^lease.*(\n)*{$").unwrap();
let string = "lease 192.168.0.1
{
";
let substitution = "\\\\$0";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}