import Foundation
let pattern = #"^lease.*(\n)*{$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
lease 192.168.0.1
{
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)