#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "'[\w ]+\$[\w]+[\w ]+'"
Local $sString = "$var = 'Hello world!';" & @CRLF & _
"" & @CRLF & _
"echo 'Lorem ipsum $var dolor sit amet'; // Match this." & @CRLF & _
"echo "Lorem ipsum 'dolor sit amet $var consectetur' adipiscing elit"; // But not this." & @CRLF & _
"echo "Lorem ipsum 'dolor sit amet \$var consectetur' adipiscing elit"; // Or this."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")