// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"'[\w ]+\$[\w]+[\w ]+'").unwrap();
let string = "$var = 'Hello world!';
echo 'Lorem ipsum $var dolor sit amet'; // Match this.
echo \"Lorem ipsum 'dolor sit amet $var consectetur' adipiscing elit\"; // But not this.
echo \"Lorem ipsum 'dolor sit amet \\$var consectetur' adipiscing elit\"; // Or this.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}