#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(feature)\/\d+$)|^(hotfix|release)\/\d+\.\d+\.\d+$|^develop$|^master$"
Local $sString = "feature" & @CRLF & _
"feature/" & @CRLF & _
"feature/asdf" & @CRLF & _
"feature/123" & @CRLF & _
"bugfix" & @CRLF & _
"bugfix/" & @CRLF & _
"bugfix/asdf" & @CRLF & _
"bugfix/123" & @CRLF & _
"temp" & @CRLF & _
"temp/" & @CRLF & _
"temp/123" & @CRLF & _
"temp/abc" & @CRLF & _
"temp/123abc" & @CRLF & _
"temp/123.abc" & @CRLF & _
"temp/123.123" & @CRLF & _
"hotfix" & @CRLF & _
"hotfix/" & @CRLF & _
"hotfix/abc" & @CRLF & _
"hotfix/123" & @CRLF & _
"hotfix/1.0.0" & @CRLF & _
"hotfix/11.11.11" & @CRLF & _
"release" & @CRLF & _
"release/" & @CRLF & _
"release/abc" & @CRLF & _
"release/123" & @CRLF & _
"release/1.0.0" & @CRLF & _
"release/11.11.11" & @CRLF & _
"support" & @CRLF & _
"support/" & @CRLF & _
"support/abc" & @CRLF & _
"support/123" & @CRLF & _
"support/1.0.0" & @CRLF & _
"support/11.11.11" & @CRLF & _
"support/1.x" & @CRLF & _
"develop" & @CRLF & _
"master"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")