#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[A-Z]\w*(?:[^\S\n]+[A-Z]\w*)*(?:[^\S\n]+[a-z]\w*)*(?=:)"
Local $sString = "Title: Consectetur adipiscg elit Description: Sed sit" & @CRLF & _
"> amet eros diam Details: Vestibulum a eros ut massa interdum" & @CRLF & _
"> consectetur Article number: AYHMNR" & @CRLF & _
"Title tEST: testing" & @CRLF & _
"Big red car:1, Small green ship: 2, Green Forest:3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")