const regex = /\b[A-Z]\w*(?:[^\S\n]+[A-Z]\w*)*(?:[^\S\n]+[a-z]\w*)*(?=:)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[A-Z]\\w*(?:[^\\S\\n]+[A-Z]\\w*)*(?:[^\\S\\n]+[a-z]\\w*)*(?=:)', 'gm')
const str = `Title: Consectetur adipiscg elit Description: Sed sit
> amet eros diam Details: Vestibulum a eros ut massa interdum
> consectetur Article number: AYHMNR
Title tEST: testing
Big red car:1, Small green ship: 2, Green Forest:3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}