$re = '/^(\w)\1(\d)\2$/';
$str = 'aa33';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);