package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?m)^>\s*`)
var str = `
On Thu, 4 Oct 2018 at 10:48, The Rounds <no-reply+dev@therounds.com> wrote:
> Physician User
>
> Physician,
> There is a new post for you!
> *Jeremy Wheaton*
> Open Community=C2=AE
>
> Post`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}