// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\sHello\s").unwrap();
let string = "<some tag> <some_nested_tag attr=\"Hello\"> Text </some_nested_tag> Hello world Hello Programming </some tag>";
let substitution = " HI ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}