package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<foo>[abc])\k<foo>`)
var str = `abccbaacacb aob a2b a42c A87d`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}