using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\bint\b|\blong\b|\bString\b)\s*(?<varName>\w+)";
string input = @"int varName = 0;
long value=0;
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}