const regex = /^\w+\s\d+\s\d+:\d+:\d+\ssvr\-.*\-nac-(01|02)\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w+\\s\\d+\\s\\d+:\\d+:\\d+\\ssvr\\-.*\\-nac-(01|02)\\s', 'gm')
const str = `May 20 10:59:30 svr-orw-nac-01 2020-05-20 17:59:30,646
May 20 11:01:01 svr-ies-nac-02 2020-05-20 18:01:01,389`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}