#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+\s\d+\s\d+:\d+:\d+\ssvr\-\w+\-nac-(01|02)\s"
Local $sString = "May 20 10:59:30 svr-orw-nac-01 2020-05-20 17:59:30,646" & @CRLF & _
"May 20 11:01:01 svr-ies-nac-02 2020-05-20 18:01:01,389"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")