import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+\\s\\d+\\s\\d+:\\d+:\\d+\\ssvr\\-\\w+\\-nac-(01|02)\\s";
final String string = "May 20 10:59:30 svr-orw-nac-01 2020-05-20 17:59:30,646\n"
+ "May 20 11:01:01 svr-ies-nac-02 2020-05-20 18:01:01,389";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}