package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^I get result one (.+?) and result two (.+?)$`)
var str = `I get result one hi and result two hello
I get result one hi and result two hello from microservice
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}