$re = '/^I get result one (.+?) and result two (.+?)$/m';
$str = 'I get result one hi and result two hello
I get result one hi and result two hello from microservice
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);