import Foundation
let pattern = #"^The thing is.*\b(S\d)(?!.*\b(?:blue|red)\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
TRUE
The thing is S2w697 and green
The thing is S2e697 and yellow
The thing is S2b697 and pink
FALSE
The thing is S25697 and blue
The thing is S256b7 and red
The thing is S2e697 and blue thing
The thing is S2b697 and red thing
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)