$re = '/.*v[0]*([0-9]+)\.[0]*([0-9]+)\.[0]*([0-9]+).*/';
$str = 'v01.02.03
v1.2.3
v1.2a
v1.00.2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);