import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{4}(?:-\\d{2}){2} \\d{2}(?::\\d{2}){2},\\d{3}(?:(?!\\d{4}(?:-\\d{2}){2} \\d{2}(?::\\d{2}){2},\\d{3})[\\s\\S])*";
final String string = "2019-09-25 11:16:39,253 [myid:] - WARN [NIOServerCxn.Factory:0.0.0.0/0.0.0.0:2181:NIOServerCnxn@357] - caught end of stream exception\n"
+ "EndOfStreamException: Unable to read additional data from client sessionid 0x16d666b95e10002, likely client has closed socket\n"
+ " at org.apache.zookeeper.server.NIOServerCnxn.doIO(NIOServerCnxn.java:228)\n"
+ " at org.apache.zookeeper.server.NIOServerCnxnFactory.run(NIOServerCnxnFactory.java:203)\n"
+ " at java.lang.Thread.run(Thread.java:745)\n"
+ "2019-09-25 11:16:39,260 [myid:] - INFO [NIOServerCxn.Factory:0.0.0.0/0.0.0.0:2181:NIOServerCnxn@1008] - Closed socket connection for client /192.168.101.231:48311 which had sessionid 0x16d666b95e10002\n"
+ "2019-09-25 11:16:40,000 [myid:] - INFO [SessionTracker:ZooKeeperServer@358] - Expiring session 0x36b63c29fbac528, timeout of 10000ms exceeded";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}