# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\-?\(.*\))"
test_str = ("363\n"
"00:22:09,395 --> 00:22:11,996\n"
" Because he did only\n"
" meet me the once.\n\n"
"364\n"
"00:22:11,998 --> 00:22:13,597\n"
" Perhaps I could...\n\n"
"365\n"
"00:22:20,105 --> 00:22:21,772\n"
" (CLAMOURING)\n\n"
"366\n"
"00:22:21,774 --> 00:22:25,009\n"
" (INDISTINCT ANNOUNCEMENT\n"
" OVER PA)\n\n"
"367\n"
"00:22:55,340 --> 00:22:58,509\n"
" (INDISTINCT ANNOUNCEMENT\n"
" OVER PA)\n\n"
"368\n"
"00:23:10,655 --> 00:23:11,389\n"
" SARAH: Excuse me.\n\n"
"369\n"
"00:23:11,391 --> 00:23:14,225\n"
" Were there any men flying\n"
" alone on this fligh")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.