#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[a-zA-Z0-9]+-){3,}[a-zA-Z0-9]+$"
Local $sString = "AA3A-123-NNN-D" & @CRLF & _
"12-OOO-12455-AS" & @CRLF & _
"AA3A-123-NNN-Dasdfasfd-23423423_234234" & @CRLF & _
"12-OOO-12455-AS123124-124123" & @CRLF & _
"123142-123123-3afdsafs"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")