using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[a-zA-Z0-9]+-){3,}[a-zA-Z0-9]+$";
string input = @"AA3A-123-NNN-D
12-OOO-12455-AS
AA3A-123-NNN-Dasdfasfd-23423423_234234
12-OOO-12455-AS123124-124123
123142-123123-3afdsafs";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}