package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[a-zA-Z0-9]+-){3,}[a-zA-Z0-9]+$`)
var str = `AA3A-123-NNN-D
12-OOO-12455-AS
AA3A-123-NNN-Dasdfasfd-23423423_234234
12-OOO-12455-AS123124-124123
123142-123123-3afdsafs`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}