$re = '/^(?:[a-zA-Z0-9]+-){3,}[a-zA-Z0-9]+$/m';
$str = 'AA3A-123-NNN-D
12-OOO-12455-AS
AA3A-123-NNN-Dasdfasfd-23423423_234234
12-OOO-12455-AS123124-124123
123142-123123-3afdsafs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);