# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\s){2,}|\s/$1/g;t' <<< "S O M E T E X T I W O U L D L I K E T O H I G H L I G H T"