#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\s){2,}|\s"
Local $sString = "S O M E T E X T I W O U L D L I K E T O H I G H L I G H T"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)