import Foundation
let pattern = #"(\s){2,}|\s"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"S O M E T E X T I W O U L D L I K E T O H I G H L I G H T"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)