$re = '/([0-9.]+)([kmbBtTqQ]*)/m';
$str = '1234.567k';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);