#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9]{1,}/2020/\w{0,}/SPV"
Local $sString = "Số: 2479/2020/ECOM/SPV - tabiimlianoi" & @CRLF & _
"Số: 2479/2020//SPV - tabiimlianoi" & @CRLF & _
"1712/2020/HDDVBC/SPV - VIMO - SPX"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")