package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-?\b\d+\b`)
var str = `+8x2+10y2-99+5=99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}