$re = '/-?\b\d+\b/';
$str = '+8x2+10y2-99+5=99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);