using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"p\.?o\.? box [^ \r\n\t]+";
string input = @"some text p.o. box 12456 Floor 105 streetName Street";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}