package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\d.]+((,[\s*\d.]+){2},\s*)[\d.]+`)
var str = []byte(`matrix(1.5, 0, 0, 2, 160, 160, 100)`)
var substitution = []byte("1$11")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}