// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\d.]+((,[\s*\d.]+){2},\s*)[\d.]+").unwrap();
let string = "matrix(1.5, 0, 0, 2, 160, 160, 100)";
let substitution = "1$11";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}