package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`([abAB])\.([abAB])`)
    var str = `a.b
a.B
A.b
A.B
1.2`
    var substitution = "\1. \2"
    
    fmt.Println(re.ReplaceAllString(str, substitution))
}