#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<="name":)(?:\w+|"(?:.+|(?0))"|\[(?:.+|(?0))\]|{(?:[^{}]|(?0))*})"
Local $sString = "{"name":{"first":"ainsley","last":"clarke","coord":{"lat":100, "lng":200}},"0":["one","two","three"],"location":{"0":"usa"},"roles":["admin","super","csr"],"test":true,"age":34}" & @CRLF & _
"" & @CRLF & _
"{"first":"ainsley","last":"clarke"}" & @CRLF & _
"{}" & @CRLF & _
"{"name":{}}" & @CRLF & _
"[]" & @CRLF & _
"{"age":29, "name":"jim"}" & @CRLF & _
"{"age":29, "name":["jim"]}" & @CRLF & _
"{"age":29, "name":[true]}" & @CRLF & _
"{"age":29, "name":true}" & @CRLF & _
"{"age":29, "name":false}" & @CRLF & _
"{"age":29, "name":null}" & @CRLF & _
"{"age":29, "name":undefined}" & @CRLF & _
"{"age":29, "name":NaN}" & @CRLF & _
"{"age":29, "name":{"first":"ainsley"}}" & @CRLF & _
"[true]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")