using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=""name"":)(?:\w+|""(?:.+|(?0))""|\[(?:.+|(?0))\]|{(?:[^{}]|(?0))*})";
string input = @"{""name"":{""first"":""ainsley"",""last"":""clarke"",""coord"":{""lat"":100, ""lng"":200}},""0"":[""one"",""two"",""three""],""location"":{""0"":""usa""},""roles"":[""admin"",""super"",""csr""],""test"":true,""age"":34}
{""first"":""ainsley"",""last"":""clarke""}
{}
{""name"":{}}
[]
{""age"":29, ""name"":""jim""}
{""age"":29, ""name"":[""jim""]}
{""age"":29, ""name"":[true]}
{""age"":29, ""name"":true}
{""age"":29, ""name"":false}
{""age"":29, ""name"":null}
{""age"":29, ""name"":undefined}
{""age"":29, ""name"":NaN}
{""age"":29, ""name"":{""first"":""ainsley""}}
[true]
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}