import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\"name\":)(?:\\w+|\"(?:.+|(?0))\"|\\[(?:.+|(?0))\\]|\\{(?:[^\\{\\}]|(?0))*\\})";
final String string = "{\"name\":{\"first\":\"ainsley\",\"last\":\"clarke\",\"coord\":{\"lat\":100, \"lng\":200}},\"0\":[\"one\",\"two\",\"three\"],\"location\":{\"0\":\"usa\"},\"roles\":[\"admin\",\"super\",\"csr\"],\"test\":true,\"age\":34}\n\n"
+ "{\"first\":\"ainsley\",\"last\":\"clarke\"}\n"
+ "{}\n"
+ "{\"name\":{}}\n"
+ "[]\n"
+ "{\"age\":29, \"name\":\"jim\"}\n"
+ "{\"age\":29, \"name\":[\"jim\"]}\n"
+ "{\"age\":29, \"name\":[true]}\n"
+ "{\"age\":29, \"name\":true}\n"
+ "{\"age\":29, \"name\":false}\n"
+ "{\"age\":29, \"name\":null}\n"
+ "{\"age\":29, \"name\":undefined}\n"
+ "{\"age\":29, \"name\":NaN}\n"
+ "{\"age\":29, \"name\":{\"first\":\"ainsley\"}}\n"
+ "[true]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}