re = /Temp:([^,]+)/m
str = 'Temp:C5E501374D0343090957F7E5929E765C931F7D3EC7A96189FDA88549D54D9E4E5DB3FC1C2, adfsafd1242412,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end