$re = '~(?<tytul>(.*))//(?<autor>(.*))//(?<rok>(.*))$~m';
$str = 'Eragon // Christopher Paolini // 2005
The Fellowship of the Ring // J. R. R. Tolkien // 1954';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);