using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"RGB = \((?:(?:\d{1,3},?){4})\)";
string input = @"RGB = (255,000,255,000)
RGB = (255,255,000,000)";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}