package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)RGB = \((?:(?:\d{1,3},?){4})\)`)
var str = `RGB = (255,000,255,000)
RGB = (255,255,000,000)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}