// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)RGB = \((?:(?:\d{1,3},?){4})\)").unwrap();
let string = "RGB = (255,000,255,000)
RGB = (255,255,000,000)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}