// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\{\{([a-zA-Z_][a-zA-Z_0-9]*)\}\}").unwrap();
let string = "{%
function check(a, b) {
if ($object[a] && (b === undefined || $object[b])) {
$write(\"checked\");
}
}
%}
<tr>
<td>{{name}}</td>
<td>{{description}}</td>
<td><input type=\"checkbox\" {%%}=\"check('load');\"></td>
<td><input type=\"checkbox\" {%%}=\"check('load', 'test');\"></td>
<td><input type=\"checkbox\" {%%}=\"check('doc');\"></td>
</tr>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}