import Foundation
let pattern = #"(@[\w]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
James Morrow @pwafork
14 mins · Like
Amy Holbrook @chivalress and it's a combination of serious shit, my dumb life, and curated Good Tweets
13 mins · Like
Stefanie Elliott Cirillo I exist to harass Nick on Twitter
11 mins · Like
Stefanie Elliott Cirillo J/k I'm @stefc and basically talk about my kids. I have hashtags such as #annaquoteoftheday and a new #veraquoteoctheday which is whatever hilarious thing my kids have said.
10 mins · Like
Bradley America @bradley_america
6 mins · Like
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)