use strict;
my $str = '1234
5678
';
my $regex = qr/(^|[^\n])\n{2}/p;
my $subst = 'TEST';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";