use strict;
my $str = 'good && toast&&guest &fast& slow||wind ||old|| new || very good';
my $regex = qr/(?<!\S)(?:\&\&|\|\|)(?!\S)/mp;
my $subst = '<<\\g<0>>>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";